Click here for the english version 
Oxy-Gen
Dernière mise à jour du logiciel :
12 mars 2016 : Version 1.39d
Le logiciel
  Accueil
  Télécharger
Documentation
  Versions
  Manuel
Les utilisateurs
  Le forum
  Question fréquentes
  Remerciements
  Participations
  Construire son site
Les liens
  Référencement
  Sites de généalogie
  Sites par Oxy-Gen
  Comparatif
 

FORUM

Message suivant : Générer un CD

Message précédent : Affichage des arbres d'ascendance

Message d'origine

Titre : PHP : Pas toutes les données !
Auteur : Tristan
Date :29/06/2006 23:11
Bonjour,

Je découvre Oxy-gen actuellement. J'ai généré, installé, chargé une version PHP/MySQL. Tout fonctionne bien, sauf que la plupart des informations ne s'affichent pas. Ni date, ni événements, ...
Juste le nom, prénom, n° SOSA, les parents et les enfants.
Pourtant, les scripts de chargements n'ont été qu'une suite de OK.


Réponse(s)

Titre : Réponse : PHP : Pas toutes les données !
Auteur : Oxy-Gen
Date :30/06/2006 22:18
Il y a une nouvelle version à télécharger. Dites-moi si c'est mieux.
Merci

Titre :
Auteur : Tristan
Date :03/07/2006 21:44
Pour optimiser mon test : que faut-il remettre en ligne pour tester ? Tout (base + données + scripts de consult) ? Juste les scripts de consult ?

Titre : Réponse : PHP : Pas toutes les données !
Auteur : Oxy-Gen
Date :04/07/2006 11:56
Juste les scripts de consultation.

Titre : Résultat du test PHP avec la 1.36i
Auteur : Tristan
Date :04/07/2006 15:54
J'ai regénéré et remonté les scripts de consultation.

Il y a beaucoup plus de choses qui s'affichent concernant une personne, mais :
- Toujours aucune date,
- Les parents apparaissent uniquement comme "?" et les enfants aussi,
- L'ordre des données est bizarre. Je cite :
* Père
* Mère
* Naissance
* Modification (???)
* Modification (???)
* Evénement
* Prénom
* Nom de famille
* Mariage
* Référence à des données utilisées comme description
* Profession

Sur la page d'accueil
- "La personne la plus ancienne..." n'est pas renseignée.
- Bandeau : Entre Patronymes et Lieux, il y a un séparateur. Option de menu manquante ?

Affichage d'un arbre :
- Aucun nom, que des "?"
- Certaines lignes de l'arbre sont sur fond blanc

Curieusement, après un peu de navigation, les noms qui étaient remplacés par des "?" se remettent à apparaître. La personne la plus ancienne est renseignée. En revanche, la ligne "Ce site vous présente une généalogie dont..." a disparu.

Titre : Dates
Auteur : Oxy-Gen
Date :05/07/2006 12:59
J'avais oublié que j'avais aussi changé le format des dates.
Vous devez aussi mettre à jour le répertoire Admin et regénérer la base.
Désolé pour cette mauvaise information.

Titre : C'est mieux, mais...
Auteur : Tristan
Date :06/07/2006 23:42
J'ai tout rechargé et effectivement, les dates apparaissent. Les "?" qui précèdent lorsqu'elle n'est pas complète (ex. ? 2006) ne sont pas très heureux.
La plupart des autres défauts constatés restent.
J'ajoute :
- L'épouse n'est pas mentionnée.
- L'index par dates est vide
- Lorsqu'un événement existe, il pourrait avantageusement être retranscrit sous la forme "type : libellé de l'événement", plutôt que
"Evénement : libellé de l'événement
Type : type"
- Il faudrait pour dire à Oxy-gen de ne pas reprendre les sources et les dates de modifications.
- ...

Titre : PHP
Auteur : Oxy-Gen
Date :10/07/2006 14:39
Il y a une nouvelle version. Pour les libellés des tag, vous pouvez les modifier dans les options.

Titre : PHP suite
Auteur : Tristan
Date :24/08/2006 16:11
Je reprends les choses là où je les avais laissé avant les vacances.
J'ai téléchargé la dernière version PHP d'Oxy-Gen et raffraichi les scripts qui ont changé. Quand je tente l'exéution : Fatal error: main(): Failed opening required 'admin/§lib_inc.php'

Pourtant, le fichier y est bien !
Une idée ?


Retour au forum

Retour au menu principal


Répondre au message

Nom/Pseudo :

Titre :

Message:

Sécurité anti-spam : veuillez saisir le chiffre neuf :


Message suivant : Générer un CD

Message précédent : Affichage des arbres d'ascendance

Copyright (C) 2000-2016